# LifterLMS <= 10.3.2 - Unauthenticated Sensitive Information Exposure via REST API Sections and Access Plans Endpoints

- **ID:** WPSEC-2026-2480
- **Plugin:** LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes (`lifterlms`), https://wordpress.org/plugins/lifterlms/
- **Affected versions:** all versions before 11.0.0
- **Fixed in:** 11.0.0 (Update to 11.0.0 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/lifterlms
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2480/

## Description

The LifterLMS plugin for WordPress is vulnerable to Sensitive Information Exposure via the REST API sections and access plans endpoints in all versions up to, and including, 10.3.2 due to missing read permission checks on the parent course or membership and missing scoping of the collection queries. This makes it possible for unauthenticated attackers to list and read sections of unpublished, private or otherwise unreadable courses, as well as hidden access plans and access plans of courses or memberships they cannot read.

## References

- https://wpsec.com/vuln/WPSEC-2026-2480/
- https://plugins.svn.wordpress.org/lifterlms/tags/11.0.0/
- https://wordpress.org/plugins/lifterlms/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2480/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
