{
 "id": "WPSEC-2026-2482",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2482/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2482/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2482/index.md",
 "title": "Dynamic Pricing With Discount Rules for WooCommerce <= 5.1.0 - Authenticated (Shop Manager+) PHP Object Injection via Rule Duplication",
 "description": "The Dynamic Pricing With Discount Rules for WooCommerce plugin for WordPress is vulnerable to PHP Object Injection via the rule duplication REST handler in all versions up to, and including, 5.1.0, due to unserialization of the copied rule's post meta values without restricting the allowed classes. One of these values, custom_product_list, is stored exactly as sent in the rule save handler's customPL parameter. This makes it possible for authenticated attackers with Shop Manager-level access and above to inject a PHP object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.",
 "plugin": {
  "slug": "aco-woo-dynamic-pricing",
  "name": "Dynamic Pricing With Discount Rules for WooCommerce",
  "full_name": "Dynamic Pricing With Discount Rules for WooCommerce",
  "wordpress_org": "https://wordpress.org/plugins/aco-woo-dynamic-pricing/",
  "advisories_url": "https://wpsec.com/vuln/plugin/aco-woo-dynamic-pricing/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/aco-woo-dynamic-pricing"
 },
 "type": "OBJECT INJECTION",
 "cwe": [
  "CWE-502"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.6,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "5.1.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 5.1.1"
  ]
 },
 "introduced_in": null,
 "fixed_in": "5.1.1",
 "remediation": "Update to 5.1.1 or later.",
 "fix_released": "2026-11-03T11:48:35+00:00",
 "published": "2026-11-04T14:58:24+00:00",
 "updated": "2026-11-04T13:58:14.686249+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2482/",
  "https://plugins.svn.wordpress.org/aco-woo-dynamic-pricing/tags/5.1.1/",
  "https://wordpress.org/plugins/aco-woo-dynamic-pricing/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/aco-woo-dynamic-pricing",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-04"
 }
}