{
 "id": "WPSEC-2026-2483",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2483/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2483/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2483/index.md",
 "title": "Dynamic Pricing With Discount Rules for WooCommerce <= 5.1.0 - Authenticated (Shop Manager+) Stored Cross-Site Scripting via Plugin Settings and Rule Label",
 "description": "The Dynamic Pricing With Discount Rules for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin settings (such as pricing table labels, custom saving messages, offer descriptions and style values) and the discount rule label in all versions up to, and including, 5.1.0, due to insufficient input sanitization and output escaping. Values saved through the plugin's REST API were printed on front-end cart and product pages without escaping, including inside style attributes. This makes it possible for authenticated attackers with Shop Manager-level access and above, who do not have the unfiltered_html capability by default, to inject arbitrary web scripts in pages that will execute whenever a user accesses an affected page.",
 "plugin": {
  "slug": "aco-woo-dynamic-pricing",
  "name": "Dynamic Pricing With Discount Rules for WooCommerce",
  "full_name": "Dynamic Pricing With Discount Rules for WooCommerce",
  "wordpress_org": "https://wordpress.org/plugins/aco-woo-dynamic-pricing/",
  "advisories_url": "https://wpsec.com/vuln/plugin/aco-woo-dynamic-pricing/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/aco-woo-dynamic-pricing"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.5,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "5.1.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 5.1.1"
  ]
 },
 "introduced_in": null,
 "fixed_in": "5.1.1",
 "remediation": "Update to 5.1.1 or later.",
 "fix_released": "2026-11-03T11:48:35+00:00",
 "published": "2026-11-04T14:58:24+00:00",
 "updated": "2026-11-04T13:58:14.686249+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2483/",
  "https://plugins.svn.wordpress.org/aco-woo-dynamic-pricing/tags/5.1.1/",
  "https://wordpress.org/plugins/aco-woo-dynamic-pricing/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/aco-woo-dynamic-pricing",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-04"
 }
}