# Dynamic Pricing With Discount Rules for WooCommerce <= 5.1.0 - Authenticated (Shop Manager+) Stored Cross-Site Scripting via Plugin Settings and Rule Label

- **ID:** WPSEC-2026-2483
- **Plugin:** Dynamic Pricing With Discount Rules for WooCommerce (`aco-woo-dynamic-pricing`), https://wordpress.org/plugins/aco-woo-dynamic-pricing/
- **Affected versions:** all versions before 5.1.1
- **Fixed in:** 5.1.1 (Update to 5.1.1 or later.)
- **Severity:** Medium 5.5 (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/aco-woo-dynamic-pricing
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2483/

## Description

The Dynamic Pricing With Discount Rules for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin settings (such as pricing table labels, custom saving messages, offer descriptions and style values) and the discount rule label in all versions up to, and including, 5.1.0, due to insufficient input sanitization and output escaping. Values saved through the plugin's REST API were printed on front-end cart and product pages without escaping, including inside style attributes. This makes it possible for authenticated attackers with Shop Manager-level access and above, who do not have the unfiltered_html capability by default, to inject arbitrary web scripts in pages that will execute whenever a user accesses an affected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2483/
- https://plugins.svn.wordpress.org/aco-woo-dynamic-pricing/tags/5.1.1/
- https://wordpress.org/plugins/aco-woo-dynamic-pricing/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2483/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
