{
 "id": "WPSEC-2026-2487",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2487/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2487/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2487/index.md",
 "title": "Advanced Form Integration <= 2.11.0 - Unauthenticated Missing Authorization to Administrator Role Change via WordPress Update User Role Action",
 "description": "The Advanced Form Integration plugin for WordPress is vulnerable to unauthorized modification of data via the WordPress \"Update User Role\" integration action in all versions up to, and including, 2.11.0. This is due to the action looking up the target account from a submitted user ID, username or email and changing its role without checking whether that account is an administrator or holds another privileged role. This makes it possible for unauthenticated attackers to demote administrators and other privileged users to the role configured in the integration, locking them out of the site's administration. Exploitation requires an active Update User Role integration whose user field is mapped to a submitted form value.",
 "plugin": {
  "slug": "advanced-form-integration",
  "name": "Advanced Form Integration",
  "full_name": "Advanced Form Integration — Connect Forms to 300+ Apps",
  "wordpress_org": "https://wordpress.org/plugins/advanced-form-integration/",
  "advisories_url": "https://wpsec.com/vuln/plugin/advanced-form-integration/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/advanced-form-integration"
 },
 "type": "NO AUTHORISATION",
 "cwe": [
  "CWE-862"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.9,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "2.4.0",
    "from_inclusive": true,
    "to": "2.11.3",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 2.4.0 before 2.11.3"
  ]
 },
 "introduced_in": "2.4.0",
 "fixed_in": "2.11.3",
 "remediation": "Update to 2.11.3 or later.",
 "fix_released": "2026-11-03T10:42:32+00:00",
 "published": "2026-11-04T14:58:24+00:00",
 "updated": "2026-11-04T13:58:57.436001+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2487/",
  "https://plugins.svn.wordpress.org/advanced-form-integration/tags/2.11.3/",
  "https://wordpress.org/plugins/advanced-form-integration/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/advanced-form-integration",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-04"
 }
}