# Advanced Form Integration <= 2.11.0 - Unauthenticated Missing Authorization to Administrator Role Change via WordPress Update User Role Action

- **ID:** WPSEC-2026-2487
- **Plugin:** Advanced Form Integration — Connect Forms to 300+ Apps (`advanced-form-integration`), https://wordpress.org/plugins/advanced-form-integration/
- **Affected versions:** from 2.4.0 before 2.11.3
- **Fixed in:** 2.11.3 (Update to 2.11.3 or later.)
- **Severity:** Medium 5.9 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N)
- **Weakness:** CWE-862
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/advanced-form-integration
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2487/

## Description

The Advanced Form Integration plugin for WordPress is vulnerable to unauthorized modification of data via the WordPress "Update User Role" integration action in all versions up to, and including, 2.11.0. This is due to the action looking up the target account from a submitted user ID, username or email and changing its role without checking whether that account is an administrator or holds another privileged role. This makes it possible for unauthenticated attackers to demote administrators and other privileged users to the role configured in the integration, locking them out of the site's administration. Exploitation requires an active Update User Role integration whose user field is mapped to a submitted form value.

## References

- https://wpsec.com/vuln/WPSEC-2026-2487/
- https://plugins.svn.wordpress.org/advanced-form-integration/tags/2.11.3/
- https://wordpress.org/plugins/advanced-form-integration/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2487/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
