# Simple Staff List <= 2.2.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'group' Shortcode Attribute

- **ID:** WPSEC-2026-2495
- **Plugin:** Simple Staff List (`simple-staff-list`), https://wordpress.org/plugins/simple-staff-list/
- **Affected versions:** all versions before 2.2.6
- **Fixed in:** 2.2.6 (Update to 2.2.6 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/simple-staff-list
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2495/

## Description

The Simple Staff List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'group' attribute of the simple-staff-list shortcode in all versions up to, and including, 2.2.5 due to insufficient output escaping when the attribute is placed into an HTML class attribute. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2495/
- https://plugins.svn.wordpress.org/simple-staff-list/tags/2.2.6/
- https://wordpress.org/plugins/simple-staff-list/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2495/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
