# Simple Staff List <= 2.2.5 - Authenticated (Editor+) Stored Cross-Site Scripting via Staff List Template

- **ID:** WPSEC-2026-2496
- **Plugin:** Simple Staff List (`simple-staff-list`), https://wordpress.org/plugins/simple-staff-list/
- **Affected versions:** all versions before 2.2.6
- **Fixed in:** 2.2.6 (Update to 2.2.6 or later.)
- **Severity:** Medium 4.4 (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/simple-staff-list
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2496/

## Description

The Simple Staff List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the staff list template settings in all versions up to, and including, 2.2.5 due to insufficient input sanitization of the template HTML for users lacking the unfiltered_html capability and missing output escaping of the saved template and CSS in the settings textareas. This makes it possible for authenticated attackers with access to the template settings (editor-level and above) to inject arbitrary web scripts that execute on the front end and in the admin area. This only affects multisite installations and installations where unfiltered_html has been disabled.

## References

- https://wpsec.com/vuln/WPSEC-2026-2496/
- https://plugins.svn.wordpress.org/simple-staff-list/tags/2.2.6/
- https://wordpress.org/plugins/simple-staff-list/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2496/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
