{
 "id": "WPSEC-2026-2497",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2497/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2497/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2497/index.md",
 "title": "UsersWP <= 1.2.80 - Authenticated (Contributor+) Stored Cross-Site Scripting via uwp_user_badge Shortcode",
 "description": "The UsersWP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the uwp_user_badge shortcode and block in all versions up to, and including, 1.2.80, due to insufficient input sanitization and output escaping on user-supplied attributes such as 'onclick', 'link', 'badge', 'hover_content' and 'hover_icon'. The 'onclick' value is written into an inline event handler, and the 'link' value is written into the badge's href without a protocol check. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "userswp",
  "name": "UsersWP",
  "full_name": "UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP",
  "wordpress_org": "https://wordpress.org/plugins/userswp/",
  "advisories_url": "https://wpsec.com/vuln/plugin/userswp/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/userswp"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "1.2.2.4",
    "from_inclusive": true,
    "to": "1.2.81",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 1.2.2.4 before 1.2.81"
  ]
 },
 "introduced_in": "1.2.2.4",
 "fixed_in": "1.2.81",
 "remediation": "Update to 1.2.81 or later.",
 "fix_released": "2026-11-03T14:40:38+00:00",
 "published": "2026-11-04T14:58:24+00:00",
 "updated": "2026-11-04T13:57:52.153354+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2497/",
  "https://plugins.svn.wordpress.org/userswp/tags/1.2.81/",
  "https://wordpress.org/plugins/userswp/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/userswp",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-04"
 }
}