# UsersWP <= 1.2.80 - Authenticated (Contributor+) Stored Cross-Site Scripting via uwp_user_badge Shortcode

- **ID:** WPSEC-2026-2497
- **Plugin:** UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP (`userswp`), https://wordpress.org/plugins/userswp/
- **Affected versions:** from 1.2.2.4 before 1.2.81
- **Fixed in:** 1.2.81 (Update to 1.2.81 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/userswp
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2497/

## Description

The UsersWP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the uwp_user_badge shortcode and block in all versions up to, and including, 1.2.80, due to insufficient input sanitization and output escaping on user-supplied attributes such as 'onclick', 'link', 'badge', 'hover_content' and 'hover_icon'. The 'onclick' value is written into an inline event handler, and the 'link' value is written into the badge's href without a protocol check. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2497/
- https://plugins.svn.wordpress.org/userswp/tags/1.2.81/
- https://wordpress.org/plugins/userswp/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2497/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
