# PowerPress Podcasting plugin by Blubrry <= 11.18.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes and Media URL

- **ID:** WPSEC-2026-2499
- **Plugin:** PowerPress Podcasting plugin by Blubrry (`powerpress`), https://wordpress.org/plugins/powerpress/
- **Affected versions:** all versions before 11.18.2
- **Fixed in:** 11.18.2 (Update to 11.18.2 or later.)
- **Severity:** Medium 4.9 (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/powerpress
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2499/

## Description

The PowerPress Podcasting plugin by Blubrry plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'powerpress' shortcode's 'url', 'width' and 'height' attributes and episode media URLs in all versions up to, and including, 11.18.0. This is due to these values being placed inside JavaScript strings in onclick handlers and inline autoplay scripts of the HTML5 audio and video players with only htmlspecialchars() escaping, which does not protect a JavaScript context. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The HTML5 audio/video players are not the default player, so the site has to be set up to use them for the media type.

## References

- https://wpsec.com/vuln/WPSEC-2026-2499/
- https://plugins.svn.wordpress.org/powerpress/tags/11.18.2/
- https://wordpress.org/plugins/powerpress/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2499/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
