# Collapse Magic <= 1.5.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes

- **ID:** WPSEC-2026-2505
- **Plugin:** Collapse Magic (`collapse-magic`), https://wordpress.org/plugins/collapse-magic/
- **Affected versions:** all versions before 1.6.1
- **Fixed in:** 1.6.1 (Update to 1.6.1 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/collapse-magic
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2505/

## Description

The Collapse Magic plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the shortcode's title, swaptitle, icon and swapicon attributes in all versions up to, and including, 1.5.0. This is due to the plugin's front-end JavaScript reading these values from data attributes and inserting them into the page as HTML without sanitization when rendering the toggle button. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2505/
- https://plugins.svn.wordpress.org/collapse-magic/tags/1.6.1/
- https://wordpress.org/plugins/collapse-magic/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2505/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
