# ЮKassa для WooCommerce <= 2.17.3 - Unauthenticated Insecure Direct Object Reference to Payment Status Disclosure via 'order-id' Parameter

- **ID:** WPSEC-2026-2510
- **Plugin:** ЮKassa для WooCommerce (`yookassa`), https://wordpress.org/plugins/yookassa/
- **Affected versions:** all versions before 2.17.4
- **Fixed in:** 2.17.4 (Update to 2.17.4 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-639
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/yookassa
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2510/

## Description

The ЮKassa для WooCommerce plugin for WordPress is vulnerable to Insecure Direct Object Reference via the 'order-id' parameter of the yookassa_check_payment AJAX action in all versions up to, and including, 2.17.3, due to the checkPaymentStatus() function looking up any order by its ID without verifying the order key, the order owner, or the user's capabilities. This makes it possible for unauthenticated attackers to retrieve the YooKassa payment status of other customers' orders and the order's payment link, which contains the order key.

## References

- https://wpsec.com/vuln/WPSEC-2026-2510/
- https://plugins.svn.wordpress.org/yookassa/tags/2.17.4/
- https://wordpress.org/plugins/yookassa/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2510/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
