{
 "id": "WPSEC-2026-2515",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2515/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2515/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2515/index.md",
 "title": "GiveWP – Donation Plugin and Fundraising Platform <= 4.19.1 - Authenticated (Give Manager+) Privilege Escalation via Donor Default User Role Setting",
 "description": "The GiveWP plugin for WordPress is vulnerable to Privilege Escalation via the 'donor_default_user_role' setting in all versions up to, and including, 4.19.1. This is due to insufficient validation of the configured role: the sanitizer only blocked the 'administrator' role for users without the manage_options capability, and the stored value was used without a capability check when donation forms created new WordPress users. This makes it possible for authenticated attackers with access to GiveWP settings, such as a Give Manager, to set the donor default role to another privileged role and obtain, or grant, accounts with privileges beyond their own.",
 "plugin": {
  "slug": "give",
  "name": "GiveWP – Donation Plugin and Fundraising Platform",
  "full_name": "GiveWP – Donation Plugin and Fundraising Platform",
  "wordpress_org": "https://wordpress.org/plugins/give/",
  "advisories_url": "https://wpsec.com/vuln/plugin/give/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/give"
 },
 "type": "PRIV",
 "cwe": [
  "CWE-269"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 7.2,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H",
  "severity": "High"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "4.19.1.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 4.19.1.1"
  ]
 },
 "introduced_in": null,
 "fixed_in": "4.19.1.1",
 "remediation": "Update to 4.19.1.1 or later.",
 "fix_released": "2026-11-03T17:39:58+00:00",
 "published": "2026-11-04T17:48:32+00:00",
 "updated": "2026-11-04T13:28:02.856698+00:00",
 "also_published_as": {
  "source": "wordfence",
  "cve": [
   "CVE-2026-118193"
  ],
  "published": "2026-11-04T16:08:12+00:00"
 },
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2515/",
  "https://plugins.svn.wordpress.org/give/tags/4.19.1.1/",
  "https://wordpress.org/plugins/give/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/give",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-04"
 }
}