# WP Inventory Manager <= 2.5.9 - Reflected Cross-Site Scripting via 'message' Parameter in Reservation Form

- **ID:** WPSEC-2026-2522
- **Plugin:** WP Inventory Manager (`wp-inventory-manager`), https://wordpress.org/plugins/wp-inventory-manager/
- **Affected versions:** all versions before 2.5.10
- **Fixed in:** 2.5.10 (Update to 2.5.10 or later.)
- **Severity:** Medium 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-inventory-manager
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2522/

## Description

The WP Inventory Manager plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'message' query parameter of the item reservation form in all versions up to, and including, 2.5.9, due to insufficient input sanitization and output escaping. The value is read from the URL, URL-decoded and printed unescaped into the front-end reservation message. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-2522/
- https://plugins.svn.wordpress.org/wp-inventory-manager/tags/2.5.10/
- https://wordpress.org/plugins/wp-inventory-manager/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2522/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
