# Számlázz.hu integráció WooCommerce-hez <= 6.3 - Unauthenticated Invoice Data Manipulation via Invoice Override Parameters

- **ID:** WPSEC-2026-2527
- **Plugin:** Integration for Szamlazz.hu and WooCommerce (`integration-for-szamlazzhu-woocommerce`), https://wordpress.org/plugins/integration-for-szamlazzhu-woocommerce/
- **Affected versions:** all versions before 6.3.1
- **Fixed in:** 6.3.1 (Update to 6.3.1 or later.)
- **Severity:** Low 3.7 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-345
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/integration-for-szamlazzhu-woocommerce
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2527/

## Description

The Integration for Szamlazz.hu and WooCommerce plugin for WordPress is vulnerable to invoice data manipulation in all versions up to, and including, 6.3 due to the invoice generation routine reading override parameters such as 'paid', 'note', 'deadline', 'completed', 'doc_type', 'lang', 'account' and 'reason' directly from the request without verifying a nonce or the origin of the request. This makes it possible for unauthenticated customers, when invoices are generated automatically during their own requests (for example at checkout or on an automated status change), to alter the generated invoice, such as marking it as paid, injecting notes, changing the deadline or language, or switching the Számlázz.hu account used.

## References

- https://wpsec.com/vuln/WPSEC-2026-2527/
- https://plugins.svn.wordpress.org/integration-for-szamlazzhu-woocommerce/tags/6.3.1/
- https://wordpress.org/plugins/integration-for-szamlazzhu-woocommerce/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2527/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
