{
 "id": "WPSEC-2026-2531",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2531/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2531/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2531/index.md",
 "title": "Co-Authors Plus <= 4.2.0 - Authenticated (Contributor+) Improper Authorization to Guest-Authored Post Editing via Username Collision",
 "description": "The Co-Authors Plus plugin for WordPress is vulnerable to Improper Authorization via the co-author capability mapping in all versions up to, and including, 4.2.0, due to the is_coauthor_for_post() function treating a registered user as a co-author whenever their user_login matches the user_login of a guest author bylined on the post, even when that guest author is not linked to the user. This makes it possible for authenticated attackers, with Contributor-level access and above, whose username matches an unlinked guest author's login, to be treated as a co-author of that guest author's posts and to view and edit posts they could not otherwise access, such as drafts and pending posts.",
 "plugin": {
  "slug": "co-authors-plus",
  "name": "Co-Authors Plus",
  "full_name": "Co-Authors Plus",
  "wordpress_org": "https://wordpress.org/plugins/co-authors-plus/",
  "advisories_url": "https://wpsec.com/vuln/plugin/co-authors-plus/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/co-authors-plus"
 },
 "type": "AUTHBYPASS",
 "cwe": [
  "CWE-863"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.2,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "3.0",
    "from_inclusive": true,
    "to": "4.2.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 3.0 before 4.2.1"
  ]
 },
 "introduced_in": "3.0",
 "fixed_in": "4.2.1",
 "remediation": "Update to 4.2.1 or later.",
 "fix_released": "2026-11-04T00:32:10+00:00",
 "published": "2026-11-05T00:45:48+00:00",
 "updated": "2026-11-04T13:57:35.503371+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2531/",
  "https://plugins.svn.wordpress.org/co-authors-plus/tags/4.2.1/",
  "https://wordpress.org/plugins/co-authors-plus/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/co-authors-plus",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-04"
 }
}