# VK All in One Expansion Unit <= 9.123.1 - Authenticated (Contributor+) Sensitive Information Exposure via CTA Block

- **ID:** WPSEC-2026-2543
- **Plugin:** VK All in One Expansion Unit (`vk-all-in-one-expansion-unit`), https://wordpress.org/plugins/vk-all-in-one-expansion-unit/
- **Affected versions:** from 9.80.0.0 before 9.124.0
- **Fixed in:** 9.124.0 (Update to 9.124.0 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-05)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/vk-all-in-one-expansion-unit
- **Fix released:** 2026-11-04
- **Published:** 2026-11-05
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2543/

## Description

The VK All in One Expansion Unit plugin for WordPress is vulnerable to Sensitive Information Exposure via the Call To Action (CTA) block in all versions up to, and including, 9.123.1. This is due to the block's render callback loading the post given in the block's postId attribute with get_post() and only rejecting trashed posts, instead of restricting it to published CTA posts. This makes it possible for authenticated attackers with Contributor-level access and above to render and view the content of draft, private, password-protected or other non-public posts of any post type.

## References

- https://wpsec.com/vuln/WPSEC-2026-2543/
- https://plugins.svn.wordpress.org/vk-all-in-one-expansion-unit/tags/9.124.0/
- https://wordpress.org/plugins/vk-all-in-one-expansion-unit/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2543/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
