{
 "id": "WPSEC-2026-2552",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2552/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2552/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2552/index.md",
 "title": "Website Builder by SeedProd - Theme Builder, Landing Page Builder, Coming Soon Page, Maintenance Mode <= 6.20.10 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'seedprodwpwidget' Shortcode",
 "description": "The Website Builder by SeedProd - Theme Builder, Landing Page Builder, Coming Soon Page, Maintenance Mode plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the [seedprodwpwidget] shortcode in all versions up to, and including, 6.20.10, due to the shortcode rendering any registered widget class, such as the Custom HTML or Text widget, with the shortcode attributes used directly as the widget instance, without running the widget's sanitizing update routine and without escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "coming-soon",
  "name": "Website Builder by SeedProd - Theme Builder, Landing Page Builder, Coming Soon Page, Maintenance Mode",
  "full_name": "Website Builder by SeedProd — Theme Builder, Landing Page Builder, Coming Soon Page, Maintenance Mode",
  "wordpress_org": "https://wordpress.org/plugins/coming-soon/",
  "advisories_url": "https://wpsec.com/vuln/plugin/coming-soon/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/coming-soon"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "6.20.11",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 6.20.11"
  ]
 },
 "introduced_in": null,
 "fixed_in": "6.20.11",
 "remediation": "Update to 6.20.11 or later.",
 "fix_released": "2026-11-04T09:14:36+00:00",
 "published": "2026-11-05T09:48:23+00:00",
 "updated": "2026-11-04T13:57:28.426295+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2552/",
  "https://plugins.svn.wordpress.org/coming-soon/tags/6.20.11/",
  "https://wordpress.org/plugins/coming-soon/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/coming-soon",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-05"
 }
}