# STAGGS <= 3.3.0 - Unauthenticated Remote Code Execution via Configurator Price Calculation

- **ID:** WPSEC-2026-2576
- **Plugin:** STAGGS – Product Configurator Toolkit (`staggs`), https://wordpress.org/plugins/staggs/
- **Affected versions:** from 1.2.1 before 3.4.0
- **Fixed in:** 3.4.0 (Update to 3.4.0 or later.)
- **Severity:** High 8.1 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H)
- **Weakness:** CWE-95
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-05)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/staggs
- **Fix released:** 2026-11-04
- **Published:** 2026-11-05
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2576/

## Description

The STAGGS plugin for WordPress is vulnerable to Remote Code Execution via the configurator price calculation in all versions up to, and including, 3.3.0, due to submitted configurator option values being concatenated into strings that are passed to PHP's eval() when unit-priced or formula-priced input fields are recalculated server-side, for example when a configured product is added to the cart. This makes it possible for unauthenticated attackers to execute arbitrary PHP code on the server, provided the site has a configurable product that uses a unit-priced or formula/measurement-priced input attribute.

## References

- https://wpsec.com/vuln/WPSEC-2026-2576/
- https://plugins.svn.wordpress.org/staggs/tags/3.4.0/
- https://wordpress.org/plugins/staggs/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2576/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
