# Theme Builder For Elementor <= 1.2.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets' 'text' Setting

- **ID:** WPSEC-2026-2577
- **Plugin:** Theme Builder For Elementor (`theme-builder-for-elementor`), https://wordpress.org/plugins/theme-builder-for-elementor/
- **Affected versions:** all versions before 2.0.0
- **Fixed in:** 2.0.0 (Update to 2.0.0 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-05)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/theme-builder-for-elementor
- **Fix released:** 2026-11-04
- **Published:** 2026-11-05
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2577/

## Description

The Theme Builder For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'text' setting of the Read More Button, Post Author, Post Date, Post Categories, Post Tags and Post Comments Elementor widgets in all versions up to, and including, 1.2.5, due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above who can edit posts with Elementor, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2577/
- https://plugins.svn.wordpress.org/theme-builder-for-elementor/tags/2.0.0/
- https://wordpress.org/plugins/theme-builder-for-elementor/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2577/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
