{
 "id": "WPSEC-2026-2585",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2585/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2585/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2585/index.md",
 "title": "EmbedPress <= 4.7.1 - Authenticated (Subscriber+) Server-Side Request Forgery via oEmbed Discovery",
 "description": "The EmbedPress plugin for WordPress is vulnerable to Server-Side Request Forgery via oEmbed discovery in all versions up to, and including, 4.7.1. This is because the bundled Embera library fetches oEmbed endpoints with its own cURL/file_get_contents client, which skips WordPress URL validation and the plugin's internal-host blocking, and some providers (such as Didacte and SlateApp) build the endpoint host from part of the user-supplied URL. The 'embedpress_get_embed_url_info' AJAX action can be called by any logged-in user without a capability or nonce check, and the classic-editor code path that registers it can be loaded by adding a request parameter. Contributors can also reach the same fetch through the plugin's shortcode. This makes it possible for authenticated attackers, with subscriber-level access and above, to make web requests to arbitrary locations originating from the web application, which can be used to query and modify information from internal services.",
 "plugin": {
  "slug": "embedpress",
  "name": "EmbedPress",
  "full_name": "EmbedPress",
  "wordpress_org": "https://wordpress.org/plugins/embedpress/",
  "advisories_url": "https://wpsec.com/vuln/plugin/embedpress/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/embedpress"
 },
 "type": "SSRF",
 "cwe": [
  "CWE-918"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "4.7.2",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 4.7.2"
  ]
 },
 "introduced_in": null,
 "fixed_in": "4.7.2",
 "remediation": "Update to 4.7.2 or later.",
 "fix_released": "2026-11-04T13:05:23+00:00",
 "published": "2026-11-05T13:50:33+00:00",
 "updated": "2026-11-05T10:27:20.751156+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2585/",
  "https://plugins.svn.wordpress.org/embedpress/tags/4.7.2/",
  "https://wordpress.org/plugins/embedpress/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/embedpress",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-11-05"
 }
}