{
 "id": "WPSEC-2026-2593",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2593/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2593/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2593/index.md",
 "title": "Tablesome Table – Contact Form DB – WPForms, CF7, Gravity, Forminator, Fluent <= 1.2.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes",
 "description": "The Tablesome Table – Contact Form DB – WPForms, CF7, Gravity, Forminator, Fluent plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the [tablesome] shortcode's 'table_id', 'post_id' and 'exclude_column_ids' attributes in all versions up to, and including, 1.2.15, due to insufficient input sanitization and output escaping when these values are printed into the table container's HTML attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "tablesome",
  "name": "Tablesome Table – Contact Form DB – WPForms, CF7, Gravity, Forminator, Fluent",
  "full_name": "Tablesome Table – Contact Form DB – WPForms, CF7, Gravity, Forminator, Fluent",
  "wordpress_org": "https://wordpress.org/plugins/tablesome/",
  "advisories_url": "https://wpsec.com/vuln/plugin/tablesome/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/tablesome"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "1.2.16",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 1.2.16"
  ]
 },
 "introduced_in": null,
 "fixed_in": "1.2.16",
 "remediation": "Update to 1.2.16 or later.",
 "fix_released": "2026-11-04T15:11:14+00:00",
 "published": "2026-11-05T15:48:17+00:00",
 "updated": "2026-11-05T09:51:26.934714+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2593/",
  "https://plugins.svn.wordpress.org/tablesome/tags/1.2.16/",
  "https://wordpress.org/plugins/tablesome/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/tablesome",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-05"
 }
}