# WP Data Access <= 5.5.90 - Authenticated (Contributor+) Stored Cross-Site Scripting via Dynamic Hyperlink Column Values

- **ID:** WPSEC-2026-2606
- **Plugin:** WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps (`wp-data-access`), https://wordpress.org/plugins/wp-data-access/
- **Affected versions:** all versions before 5.5.91
- **Fixed in:** 5.5.91 (Update to 5.5.91 or later.)
- **Severity:** Medium 4.9 (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-05)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-data-access
- **Fix released:** 2026-11-04
- **Published:** 2026-11-05
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2606/

## Description

The WP Data Access plugin for WordPress is vulnerable to Stored Cross-Site Scripting via column values substituted into dynamic hyperlinks shown in data entry forms in all versions up to, and including, 5.5.90, due to insufficient output escaping. Row values replace the $$column$$ placeholders in the hyperlink template, and the result was echoed into the href attribute and the link markup without escaping. This makes it possible for authenticated attackers, with contributor-level access and above, who can store data in a table that has a dynamic hyperlink configured, to inject arbitrary web scripts that execute whenever a user opens the affected record in the form.

## References

- https://wpsec.com/vuln/WPSEC-2026-2606/
- https://plugins.svn.wordpress.org/wp-data-access/tags/5.5.91/
- https://wordpress.org/plugins/wp-data-access/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2606/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
