# WP Data Access <= 5.5.90 - Authenticated (Subscriber+) SQL Injection via Environment Variable Substitution

- **ID:** WPSEC-2026-2608
- **Plugin:** WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps (`wp-data-access`), https://wordpress.org/plugins/wp-data-access/
- **Affected versions:** from 4.2.0 before 5.5.91
- **Fixed in:** 5.5.91 (Update to 5.5.91 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N)
- **Weakness:** CWE-89
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-05)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-data-access
- **Fix released:** 2026-11-04
- **Published:** 2026-11-05
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2608/

## Description

The WP Data Access plugin for WordPress is vulnerable to SQL Injection via the $$EMAIL$$ (and $$USER$$) environment variables in default WHERE clauses in all versions up to, and including, 5.5.90, due to the current user's email address and login being placed into the SQL query by plain string replacement, without escaping or preparation. This makes it possible for authenticated attackers, with subscriber-level access and above, whose account email address contains quote characters (which WordPress allows), to append additional SQL to existing queries and extract sensitive information from the database. Exploitation requires that a default WHERE clause using these environment variables has been configured.

## References

- https://wpsec.com/vuln/WPSEC-2026-2608/
- https://plugins.svn.wordpress.org/wp-data-access/tags/5.5.91/
- https://wordpress.org/plugins/wp-data-access/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2608/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
