# Leaky Paywall <= 5.3.2 - Unauthenticated Payment Bypass via PayPal IPN for Another Merchant Account

- **ID:** WPSEC-2026-2618
- **Plugin:** Leaky Paywall (`leaky-paywall`), https://wordpress.org/plugins/leaky-paywall/
- **Affected versions:** all versions before 5.3.3
- **Fixed in:** 5.3.3 (Update to 5.3.3 or later.)
- **Severity:** Low 3.7 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-345
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-05)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/leaky-paywall
- **Fix released:** 2026-11-04
- **Published:** 2026-11-05
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2618/

## Description

The Leaky Paywall plugin for WordPress is vulnerable to a payment bypass via the PayPal Standard IPN listener in all versions up to, and including, 5.3.2. This is due to the plugin not checking that a PayPal-verified IPN was for a payment to the site's configured PayPal account. This makes it possible for unauthenticated attackers to send a genuine IPN from a payment made to an account they control to the site's listener and obtain a paid subscription without paying the publisher.

## References

- https://wpsec.com/vuln/WPSEC-2026-2618/
- https://plugins.svn.wordpress.org/leaky-paywall/tags/5.3.3/
- https://wordpress.org/plugins/leaky-paywall/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2618/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
