# Leaky Paywall <= 5.3.2 - Unauthenticated Payment Bypass via Forged PayPal IPN

- **ID:** WPSEC-2026-2619
- **Plugin:** Leaky Paywall (`leaky-paywall`), https://wordpress.org/plugins/leaky-paywall/
- **Affected versions:** from 5.0.8 before 5.3.3
- **Fixed in:** 5.3.3 (Update to 5.3.3 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-345
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-05)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/leaky-paywall
- **Fix released:** 2026-11-04
- **Published:** 2026-11-05
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2619/

## Description

The Leaky Paywall plugin for WordPress is vulnerable to a payment bypass via the PayPal Standard IPN listener in versions 5.0.8 up to, and including, 5.3.2. This is due to insufficient verification of data authenticity: when PayPal's verification endpoint did not answer VERIFIED, the plugin fell back to a self-validation that only checked request fields the sender controls (receiver email, payment status, invoice format, amount and the custom email). This makes it possible for unauthenticated attackers to forge PayPal payment notifications and create or activate paid subscriptions without paying.

## References

- https://wpsec.com/vuln/WPSEC-2026-2619/
- https://plugins.svn.wordpress.org/leaky-paywall/tags/5.3.3/
- https://wordpress.org/plugins/leaky-paywall/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2619/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
