{
 "id": "WPSEC-2026-2622",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2622/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2622/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2622/index.md",
 "title": "RSS Aggregator by Feedzy <= 5.2.13 - Unauthenticated Stored Cross-Site Scripting via Imported Feed Item Titles",
 "description": "The RSS Aggregator by Feedzy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via imported feed item titles in all versions up to, and including, 5.2.13, due to insufficient input sanitization of feed item titles, which are HTML-entity-decoded and then used unchanged as attachment titles when featured images are sideloaded during feed imports. This makes it possible for unauthenticated attackers who control the content of a feed being imported by the site to inject arbitrary web scripts into attachment titles that will execute whenever a user accesses a page where those titles are rendered. Exploitation requires the site to import a feed whose content the attacker controls with featured image import enabled. The script markup is kept only when the import runs as a user with the unfiltered_html capability, such as an administrator running the import manually.",
 "plugin": {
  "slug": "feedzy-rss-feeds",
  "name": "RSS Aggregator by Feedzy",
  "full_name": "RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator",
  "wordpress_org": "https://wordpress.org/plugins/feedzy-rss-feeds/",
  "advisories_url": "https://wpsec.com/vuln/plugin/feedzy-rss-feeds/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/feedzy-rss-feeds"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.4,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "3.4.0",
    "from_inclusive": true,
    "to": "5.2.14",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 3.4.0 before 5.2.14"
  ]
 },
 "introduced_in": "3.4.0",
 "fixed_in": "5.2.14",
 "remediation": "Update to 5.2.14 or later.",
 "fix_released": "2026-11-04T21:24:51+00:00",
 "published": "2026-11-05T21:42:42+00:00",
 "updated": "2026-11-05T09:51:08.721386+00:00",
 "also_published_as": {
  "source": "wordfence",
  "cve": [
   "CVE-2026-120035"
  ],
  "published": "2026-11-05T22:21:07+00:00"
 },
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2622/",
  "https://plugins.svn.wordpress.org/feedzy-rss-feeds/tags/5.2.14/",
  "https://wordpress.org/plugins/feedzy-rss-feeds/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/feedzy-rss-feeds",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-05"
 }
}