{
 "id": "WPSEC-2026-2623",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2623/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2623/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2623/index.md",
 "title": "Optimole <= 4.2.18 - Authenticated (Contributor+) Stored Cross-Site Scripting via Image Tag Attribute Values",
 "description": "The Optimole plugin for WordPress is vulnerable to Stored Cross-Site Scripting via image tag attribute values in versions 4.1.0 up to, and including, 4.2.18, due to insufficient output escaping when the plugin adds missing width and height attributes to image tags. The plugin inserted the quoted width and height attributes with a plain string replacement on the text 'data-opt-id=', and that text can also appear inside an attribute value written by the post author, such as alt text. The inserted double quotes then close that value, so text the author placed after it is read as new attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "optimole-wp",
  "name": "Optimole",
  "full_name": "Optimole – Optimize Images | Convert WebP & AVIF | CDN & Lazy Load | Image Optimization",
  "wordpress_org": "https://wordpress.org/plugins/optimole-wp/",
  "advisories_url": "https://wpsec.com/vuln/plugin/optimole-wp/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/optimole-wp"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "4.1.0",
    "from_inclusive": true,
    "to": "4.2.19",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 4.1.0 before 4.2.19"
  ]
 },
 "introduced_in": "4.1.0",
 "fixed_in": "4.2.19",
 "remediation": "Update to 4.2.19 or later.",
 "fix_released": "2026-11-04T21:31:49+00:00",
 "published": "2026-11-05T21:42:42+00:00",
 "updated": "2026-11-05T09:51:20.813644+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2623/",
  "https://plugins.svn.wordpress.org/optimole-wp/tags/4.2.19/",
  "https://wordpress.org/plugins/optimole-wp/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/optimole-wp",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-05"
 }
}