# Mang Board <= 2.4.7 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Post Content

- **ID:** WPSEC-2026-2628
- **Plugin:** Mang Board (`mangboard`), https://wordpress.org/plugins/mangboard/
- **Affected versions:** all versions before 2.4.8
- **Fixed in:** 2.4.8 (Update to 2.4.8 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-05)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/mangboard
- **Fix released:** 2026-11-05
- **Published:** 2026-11-06
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2628/

## Description

The Mang Board plugin for WordPress is vulnerable to Stored Cross-Site Scripting via board post content in all versions up to, and including, 2.4.7, due to content only being purified on save when the user-supplied 'data_type' parameter contains 'html', the 'data_type' value being updatable on modification without resubmitting content, and HTML content only being purified on output for posts written by guests (level 0). This makes it possible for authenticated attackers with board member access (Subscriber-level) and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2628/
- https://plugins.svn.wordpress.org/mangboard/tags/2.4.8/
- https://wordpress.org/plugins/mangboard/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2628/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
