# Events Manager – Calendar, Bookings, Tickets, Appointments and more! <= 7.4.12 - Authenticated (Contributor+) Sensitive Information Exposure via 'event' and 'location' Shortcodes

- **ID:** WPSEC-2026-2641
- **Plugin:** Events Manager – Calendar, Bookings, Tickets, Appointments and more! (`events-manager`), https://wordpress.org/plugins/events-manager/
- **Affected versions:** all versions before 7.4.13
- **Fixed in:** 7.4.13 (Update to 7.4.13 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-06)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/events-manager
- **Fix released:** 2026-11-05
- **Published:** 2026-11-06
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2641/

## Description

The Events Manager plugin for WordPress is vulnerable to Sensitive Information Exposure via the [event] and [location] shortcodes in all versions up to, and including, 7.4.12. This is due to the shortcodes rendering any event or location given by its 'event', 'location' or 'post_id' attribute without checking that the current visitor can read that post or has unlocked its password. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the details of other users' draft, pending or password-protected events and locations.

## References

- https://wpsec.com/vuln/WPSEC-2026-2641/
- https://plugins.svn.wordpress.org/events-manager/tags/7.4.13/
- https://wordpress.org/plugins/events-manager/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2641/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
