{
 "id": "WPSEC-2026-2656",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2656/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2656/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2656/index.md",
 "title": "WPForms <= 2.0.3.1 - Unauthenticated Email Field Validation Bypass to Notification Recipient Injection",
 "description": "The WPForms plugin for WordPress is vulnerable to Email Validation Bypass via the Email field in all versions up to, and including, 2.0.3.1, due to the wpforms_is_email() function accepting any value containing a '{...}' smart tag pattern as a valid email address, including values submitted by visitors in the Email field. This makes it possible for unauthenticated attackers to submit an arbitrary comma-separated list of addresses (for example 'a@example.com,b@example.com,{x}') as an email, which, on forms whose notification Send To or CC setting uses that Email field, causes the site to send the notification email to multiple attacker-chosen recipients.",
 "plugin": {
  "slug": "wpforms-lite",
  "name": "WPForms",
  "full_name": "WPForms – AI Form Builder for WordPress – Contact Forms, Payment Forms, Survey Form, Quiz & More",
  "wordpress_org": "https://wordpress.org/plugins/wpforms-lite/",
  "advisories_url": "https://wpsec.com/vuln/plugin/wpforms-lite/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/wpforms-lite"
 },
 "type": "BYPASS",
 "cwe": [
  "CWE-20"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 3.7,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N",
  "severity": "Low"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.0.4",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.0.4"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.0.4",
 "remediation": "Update to 2.0.4 or later.",
 "fix_released": "2026-11-05T12:07:43+00:00",
 "published": "2026-11-06T12:43:54+00:00",
 "updated": "2026-11-06T11:59:09.493938+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2656/",
  "https://plugins.svn.wordpress.org/wpforms-lite/tags/2.0.4/",
  "https://wordpress.org/plugins/wpforms-lite/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/wpforms-lite",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-11-06"
 }
}