# FluentCommunity – Ultra-Fast High-Performance Social Network, Community, LMS & Online Courses <= 2.12.0 - Cross-Site Request Forgery to Invitation Acceptance

- **ID:** WPSEC-2026-2661
- **Plugin:** FluentCommunity – Ultra-Fast High-Performance Social Network, Community, LMS & Online Courses (`fluent-community`), https://wordpress.org/plugins/fluent-community/
- **Affected versions:** all versions before 2.13.0
- **Fixed in:** 2.13.0 (Update to 2.13.0 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-352
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-06)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/fluent-community
- **Fix released:** 2026-11-05
- **Published:** 2026-11-06
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2661/

## Description

The FluentCommunity plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.12.0 due to missing nonce validation on the 'auto_accept' invitation parameter of the auth page and on the logged-in path of the fcom_user_registration AJAX action, which still processed an 'invitation_token'. This makes it possible for unauthenticated attackers to force a logged-in user to accept a shareable link invitation, joining them to a space or community without consent, via a forged request granted they can trick the user into performing an action such as clicking a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-2661/
- https://plugins.svn.wordpress.org/fluent-community/tags/2.13.0/
- https://wordpress.org/plugins/fluent-community/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2661/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
