# Another Mailchimp Widget <= 2.1.0 - Improper Certificate Validation in Mailchimp API Requests

- **ID:** WPSEC-2026-2664
- **Plugin:** Another Mailchimp Widget (`another-mailchimp-widget`), https://wordpress.org/plugins/another-mailchimp-widget/
- **Affected versions:** all versions before 2.2.0
- **Fixed in:** 2.2.0 (Update to 2.2.0 or later.)
- **Severity:** Medium 5.9 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N)
- **Weakness:** CWE-295
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-06)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/another-mailchimp-widget
- **Fix released:** 2026-11-05
- **Published:** 2026-11-06
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2664/

## Description

The Another Mailchimp Widget plugin for WordPress is vulnerable to improper certificate validation in all versions up to, and including, 2.1.0 due to TLS certificate verification being disabled ('sslverify' => false) for Mailchimp API requests that carry the API key in an HTTP Basic authorization header. This makes it possible for unauthenticated attackers in a man-in-the-middle network position to intercept these requests and steal the site's Mailchimp API key.

## References

- https://wpsec.com/vuln/WPSEC-2026-2664/
- https://plugins.svn.wordpress.org/another-mailchimp-widget/tags/2.2.0/
- https://wordpress.org/plugins/another-mailchimp-widget/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2664/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
