# woo-delivery <= 1.3.90 - Authenticated (Subscriber+) Missing Authorization to Plugin Settings Update

- **ID:** WPSEC-2026-2670
- **Plugin:** woo-delivery (`woo-delivery`), https://wordpress.org/plugins/woo-delivery/
- **Affected versions:** all versions before 1.3.91
- **Fixed in:** 1.3.91 (Update to 1.3.91 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-862
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-06)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/woo-delivery
- **Fix released:** 2026-11-05
- **Published:** 2026-11-06
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2670/

## Description

The woo-delivery plugin for WordPress is vulnerable to unauthorized modification of data via its AJAX settings-save actions (delivery options, delivery/pickup date and time, off days, localization and other settings) in all versions up to, and including, 1.3.90, due to a missing capability check on the handlers, which only verify a nonce that is also printed for any visitor of the checkout page. This makes it possible for authenticated attackers, with subscriber-level access and above, to overwrite the plugin's settings, for example to disable or reconfigure delivery/pickup date and time fields, change off days, and alter checkout labels, notices and custom CSS.

## References

- https://wpsec.com/vuln/WPSEC-2026-2670/
- https://plugins.svn.wordpress.org/woo-delivery/tags/1.3.91/
- https://wordpress.org/plugins/woo-delivery/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2670/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
