{
 "id": "WPSEC-2026-2682",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2682/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2682/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2682/index.md",
 "title": "Social Slider Feed <= 2.3.8 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'slidespeed' Feed Setting",
 "description": "The Social Slider Feed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'slidespeed' feed setting in all versions up to, and including, 2.3.8 due to insufficient input sanitization and the value being printed unquoted into inline JavaScript in the slider templates, where esc_js() offers no protection. Combined with the missing capability check on the feed editing pages, this makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts that execute whenever a user accesses a page displaying the affected feed.",
 "plugin": {
  "slug": "instagram-slider-widget",
  "name": "Social Slider Feed",
  "full_name": "Social Slider Feed – Social Media Feed & Gallery Widgets",
  "wordpress_org": "https://wordpress.org/plugins/instagram-slider-widget/",
  "advisories_url": "https://wpsec.com/vuln/plugin/instagram-slider-widget/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/instagram-slider-widget"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "2.0.0",
    "from_inclusive": true,
    "to": "2.3.9",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 2.0.0 before 2.3.9"
  ]
 },
 "introduced_in": "2.0.0",
 "fixed_in": "2.3.9",
 "remediation": "Update to 2.3.9 or later.",
 "fix_released": "2026-11-05T20:51:13+00:00",
 "published": "2026-11-06T21:41:15+00:00",
 "updated": "2026-11-06T12:02:30.851848+00:00",
 "also_published_as": {
  "source": "wordfence",
  "cve": [
   "CVE-2026-121519"
  ],
  "published": "2026-11-06T13:51:22+00:00"
 },
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2682/",
  "https://plugins.svn.wordpress.org/instagram-slider-widget/tags/2.3.9/",
  "https://wordpress.org/plugins/instagram-slider-widget/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/instagram-slider-widget",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-07"
 }
}