# Social Slider Feed <= 2.3.8 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'slidespeed' Feed Setting

- **ID:** WPSEC-2026-2682
- **Plugin:** Social Slider Feed – Social Media Feed & Gallery Widgets (`instagram-slider-widget`), https://wordpress.org/plugins/instagram-slider-widget/
- **Affected versions:** from 2.0.0 before 2.3.9
- **Fixed in:** 2.3.9 (Update to 2.3.9 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-07)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/instagram-slider-widget
- **Fix released:** 2026-11-05
- **Published:** 2026-11-06
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2682/

## Description

The Social Slider Feed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'slidespeed' feed setting in all versions up to, and including, 2.3.8 due to insufficient input sanitization and the value being printed unquoted into inline JavaScript in the slider templates, where esc_js() offers no protection. Combined with the missing capability check on the feed editing pages, this makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts that execute whenever a user accesses a page displaying the affected feed.

Also published later by wordfence as CVE-2026-121519.

## References

- https://wpsec.com/vuln/WPSEC-2026-2682/
- https://plugins.svn.wordpress.org/instagram-slider-widget/tags/2.3.9/
- https://wordpress.org/plugins/instagram-slider-widget/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2682/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
