# MxChat <= 3.2.27 - Unauthenticated Sensitive Information Exposure via Chat Error Messages

- **ID:** WPSEC-2026-2688
- **Plugin:** MxChat – AI Chatbot & Content Generation for WordPress (`mxchat-basic`), https://wordpress.org/plugins/mxchat-basic/
- **Affected versions:** from 3.2.6 before 3.2.28
- **Fixed in:** 3.2.28 (Update to 3.2.28 or later.)
- **Severity:** Low 3.7 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-209
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-07)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/mxchat-basic
- **Fix released:** 2026-11-06
- **Published:** 2026-11-07
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2688/

## Description

The MxChat plugin for WordPress is vulnerable to Sensitive Information Exposure via chat error messages in all versions up to, and including, 3.2.27. This is due to raw error text from Custom Provider (OpenAI-compatible) chat and embedding requests being returned unchanged in the public chat AJAX response. This includes the WordPress HTTP transport error, which names the endpoint's host and port. This makes it possible for unauthenticated attackers to obtain internal backend details, such as the address and port of a self-hosted model server, by sending chat messages while the configured provider fails or cannot be reached.

## References

- https://wpsec.com/vuln/WPSEC-2026-2688/
- https://plugins.svn.wordpress.org/mxchat-basic/tags/3.2.28/
- https://wordpress.org/plugins/mxchat-basic/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2688/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
