{
 "id": "WPSEC-2026-2692",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2692/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2692/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2692/index.md",
 "title": "LIQUID SPEECH BALLOON <= 1.2.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via Avatar Settings",
 "description": "The LIQUID SPEECH BALLOON plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the avatar settings in all versions up to, and including, 1.2.7, due to insufficient validation of the submitted avatar numbers (array keys of the liquid_speech_balloon_img and liquid_speech_balloon_name settings), which are output without escaping into an inline style block on every page. The settings page is also available to any user with the edit_posts capability. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "liquid-speech-balloon",
  "name": "LIQUID SPEECH BALLOON",
  "full_name": "LIQUID SPEECH BALLOON",
  "wordpress_org": "https://wordpress.org/plugins/liquid-speech-balloon/",
  "advisories_url": "https://wpsec.com/vuln/plugin/liquid-speech-balloon/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/liquid-speech-balloon"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "1.1.4",
    "from_inclusive": true,
    "to": "1.2.8",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 1.1.4 before 1.2.8"
  ]
 },
 "introduced_in": "1.1.4",
 "fixed_in": "1.2.8",
 "remediation": "Update to 1.2.8 or later.",
 "fix_released": "2026-11-06T06:16:45+00:00",
 "published": "2026-11-07T06:40:50+00:00",
 "updated": "2026-11-06T12:02:51.359869+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2692/",
  "https://plugins.svn.wordpress.org/liquid-speech-balloon/tags/1.2.8/",
  "https://wordpress.org/plugins/liquid-speech-balloon/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/liquid-speech-balloon",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-07"
 }
}