# The ShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution with eCommerce Templates & Woo Widgets <= 4.9.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Product Rating Widget

- **ID:** WPSEC-2026-2693
- **Plugin:** ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets (`shopengine`), https://wordpress.org/plugins/shopengine/
- **Affected versions:** from 3.0.0 before 4.9.9
- **Fixed in:** 4.9.9 (Update to 4.9.9 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-07)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/shopengine
- **Fix released:** 2026-11-06
- **Published:** 2026-11-07
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2693/

## Description

The ShopEngine plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Rating Singular Label' and 'Rating Plural Label' settings of the Product Rating widget in all versions up to, and including, 4.9.8, due to insufficient output escaping. The labels are concatenated into a printf format string and printed without escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2693/
- https://plugins.svn.wordpress.org/shopengine/tags/4.9.9/
- https://wordpress.org/plugins/shopengine/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2693/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
