# Live Composer <= 2.1.23 - Authenticated (Contributor+) Stored Cross-Site Scripting via Module Area Shortcode Attributes

- **ID:** WPSEC-2026-2701
- **Plugin:** Live Composer – Free WordPress Website Builder (`live-composer-page-builder`), https://wordpress.org/plugins/live-composer-page-builder/
- **Affected versions:** all versions before 2.1.24
- **Fixed in:** 2.1.24 (Update to 2.1.24 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-07)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/live-composer-page-builder
- **Fix released:** 2026-11-06
- **Published:** 2026-11-07
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2701/

## Description

The Live Composer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the dslc_modules_area shortcode attributes in all versions up to, and including, 2.1.23, due to insufficient input sanitization and output escaping of attributes such as size, the instance ID and the custom class, which are placed into HTML attributes, and of Module Area style values placed into inline CSS. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2701/
- https://plugins.svn.wordpress.org/live-composer-page-builder/tags/2.1.24/
- https://wordpress.org/plugins/live-composer-page-builder/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2701/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
