{
 "id": "WPSEC-2026-2707",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2707/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2707/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2707/index.md",
 "title": "Log in with Google <= 1.4.4 - Unauthenticated Login Cross-Site Request Forgery via OAuth and One Tap State Validation",
 "description": "The Log in with Google plugin for WordPress is vulnerable to Cross-Site Request Forgery via the OAuth callback and the One Tap 'validate_id_token' AJAX action in all versions up to, and including, 1.4.4, due to missing binding of the login state to the visitor's browser. The OAuth callback relied only on a WordPress nonce, which is the same for every logged-out visitor, and the One Tap token handler did not validate the state at all. This makes it possible for unauthenticated attackers to log a victim into the attacker's own account by tricking them into following a crafted link or visiting a malicious page. Anything the victim then enters on the site is saved to the attacker's account.",
 "plugin": {
  "slug": "login-with-google",
  "name": "Log in with Google",
  "full_name": "Log in with Google",
  "wordpress_org": "https://wordpress.org/plugins/login-with-google/",
  "advisories_url": "https://wpsec.com/vuln/plugin/login-with-google/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/login-with-google"
 },
 "type": "CSRF",
 "cwe": [
  "CWE-352"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "1.4.5",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 1.4.5"
  ]
 },
 "introduced_in": null,
 "fixed_in": "1.4.5",
 "remediation": "Update to 1.4.5 or later.",
 "fix_released": "2026-11-06T11:41:29+00:00",
 "published": "2026-11-07T11:42:17+00:00",
 "updated": "2026-11-07T11:06:28.858044+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2707/",
  "https://plugins.svn.wordpress.org/login-with-google/tags/1.4.5/",
  "https://wordpress.org/plugins/login-with-google/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/login-with-google",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-07"
 }
}