# Falang multilanguage for WordPress <= 1.4.6 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Exposure and Language Order Modification via AJAX Actions

- **ID:** WPSEC-2026-2724
- **Plugin:** Falang multilanguage for WordPress (`falang`), https://wordpress.org/plugins/falang/
- **Affected versions:** all versions before 1.4.7
- **Fixed in:** 1.4.7 (Update to 1.4.7 or later.)
- **Severity:** High 7.1 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N)
- **Weakness:** CWE-862
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-07)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/falang
- **Fix released:** 2026-11-06
- **Published:** 2026-11-07
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2724/

## Description

The Falang multilanguage for WordPress plugin for WordPress is vulnerable to unauthorized access and modification of data via several AJAX actions, including falang_option_translation, falang_post_translation and falang_language_ordering, in all versions up to, and including, 1.4.6, due to missing capability checks. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read the value of arbitrary scalar site options (which may hold credentials or API keys), view the content of any post including private and draft posts, and change the order of the site's languages.

## References

- https://wpsec.com/vuln/WPSEC-2026-2724/
- https://plugins.svn.wordpress.org/falang/tags/1.4.7/
- https://wordpress.org/plugins/falang/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2724/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
