{
 "id": "WPSEC-2026-2725",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2725/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2725/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2725/index.md",
 "title": "GeoDirectory <= 2.8.202 - Unauthenticated Reflected Cross-Site Scripting via Location Replacement Variables",
 "description": "The GeoDirectory plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'country', 'region', 'city' and 'neighbourhood' query parameters in all versions up to, and including, 2.8.202, due to insufficient input sanitization and output escaping. The values are inserted into the location replacement variables (such as %%location_single%% and %%in_location_single%%) used in GeoDirectory page titles, meta titles and category descriptions. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a crafted link.",
 "plugin": {
  "slug": "geodirectory",
  "name": "GeoDirectory",
  "full_name": "GeoDirectory – WP Business Directory Plugin and Classified Listings Directory",
  "wordpress_org": "https://wordpress.org/plugins/geodirectory/",
  "advisories_url": "https://wpsec.com/vuln/plugin/geodirectory/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/geodirectory"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.1,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.8.203",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.8.203"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.8.203",
 "remediation": "Update to 2.8.203 or later.",
 "fix_released": "2026-11-06T17:50:12+00:00",
 "published": "2026-11-07T18:45:18+00:00",
 "updated": "2026-11-07T11:06:25.981586+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2725/",
  "https://plugins.svn.wordpress.org/geodirectory/tags/2.8.203/",
  "https://wordpress.org/plugins/geodirectory/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/geodirectory",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-07"
 }
}