# Envo's Templates & Widgets for Elementor and WooCommerce <= 1.4.28 - Unauthenticated Sensitive Information Exposure via etww_ajax_search AJAX Action

- **ID:** WPSEC-2026-2726
- **Plugin:** Envo’s Templates & Widgets for Elementor and WooCommerce (`envo-elementor-for-woocommerce`), https://wordpress.org/plugins/envo-elementor-for-woocommerce/
- **Affected versions:** all versions before 2.0.0
- **Fixed in:** 2.0.0 (Update to 2.0.0 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-07)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/envo-elementor-for-woocommerce
- **Fix released:** 2026-11-06
- **Published:** 2026-11-07
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2726/

## Description

The Envo’s Templates & Widgets for Elementor and WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure via the etww_ajax_search AJAX action in all versions up to, and including, 1.4.28. This is due to the handler accepting any post type from the request without limiting it to public, searchable post types. This makes it possible for unauthenticated attackers to list and search the titles and links of published entries of non-public post types, such as WooCommerce coupon codes.

## References

- https://wpsec.com/vuln/WPSEC-2026-2726/
- https://plugins.svn.wordpress.org/envo-elementor-for-woocommerce/tags/2.0.0/
- https://wordpress.org/plugins/envo-elementor-for-woocommerce/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2726/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
