{
 "id": "WPSEC-2026-2741",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2741/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2741/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2741/index.md",
 "title": "Events Made Easy <= 3.3.5 - Unauthenticated Reflected Cross-Site Scripting via Bundled Fondy SDK Example Scripts",
 "description": "The Events Made Easy plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the bundled Fondy payment SDK test and example scripts (such as payment_gateways/fondy/result.php and payment_gateways/fondy/examples/result.php) in all versions up to, and including, 3.3.5, due to insufficient output escaping. The scripts can be requested directly, turn on display_errors, and print the submitted request data back to the visitor without escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute in a victim's browser if they can trick the victim into submitting a crafted request, such as by visiting a malicious page with an auto-submitting form.",
 "plugin": {
  "slug": "events-made-easy",
  "name": "Events Made Easy",
  "full_name": "Events Made Easy",
  "wordpress_org": "https://wordpress.org/plugins/events-made-easy/",
  "advisories_url": "https://wpsec.com/vuln/plugin/events-made-easy/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/events-made-easy"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.1,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.3.6",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.3.6"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.3.6",
 "remediation": "Update to 3.3.6 or later.",
 "fix_released": "2026-11-07T09:43:57+00:00",
 "published": "2026-11-08T13:40:54+00:00",
 "updated": "2026-11-08T13:08:12.017821+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2741/",
  "https://plugins.svn.wordpress.org/events-made-easy/tags/3.3.6/",
  "https://wordpress.org/plugins/events-made-easy/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/events-made-easy",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-08"
 }
}