# Events Made Easy <= 3.3.5 - Unauthenticated Reflected Cross-Site Scripting via Bundled Fondy SDK Example Scripts

- **ID:** WPSEC-2026-2741
- **Plugin:** Events Made Easy (`events-made-easy`), https://wordpress.org/plugins/events-made-easy/
- **Affected versions:** all versions before 3.3.6
- **Fixed in:** 3.3.6 (Update to 3.3.6 or later.)
- **Severity:** Medium 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-08)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/events-made-easy
- **Fix released:** 2026-11-07
- **Published:** 2026-11-08
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2741/

## Description

The Events Made Easy plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the bundled Fondy payment SDK test and example scripts (such as payment_gateways/fondy/result.php and payment_gateways/fondy/examples/result.php) in all versions up to, and including, 3.3.5, due to insufficient output escaping. The scripts can be requested directly, turn on display_errors, and print the submitted request data back to the visitor without escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute in a victim's browser if they can trick the victim into submitting a crafted request, such as by visiting a malicious page with an auto-submitting form.

## References

- https://wpsec.com/vuln/WPSEC-2026-2741/
- https://plugins.svn.wordpress.org/events-made-easy/tags/3.3.6/
- https://wordpress.org/plugins/events-made-easy/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2741/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
