Better Post & Filter Widgets for Elementor <= 1.9.1 - Authenticated (Subscriber+) Sensitive Information Exposure via Filter REST Route

Low 3.1 CWE-285Fixed in 1.9.2
ID
WPSEC-2026-1651
Plugin
Better Post & Filter Widgets for Elementor (better-post-filter-widgets-for-elementor)
Affected
all versions before 1.9.2
Remediation
Update to 1.9.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-285
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-26
Attack surface
Better Post & Filter Widgets for Elementor on WPSec AttackSurface
Fix released
Published

Description

The Better Post & Filter Widgets for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure via the /bpfwe/v1/filter REST route in all versions up to, and including, 1.9.1. This is because the route only checks whether the visitor is logged in, not whether they can read the requested document, before it renders elements of unpublished Elementor templates and pages. This makes it possible for authenticated attackers, with subscriber-level access and above, to view the rendered content of elements in draft and private templates and pages, provided they know the element's ID.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0