Vulnerabilities / Better Payment / WPSEC-2026-1661
Better Payment <= 2.4.2 - Unauthenticated Sensitive Information Exposure via Password-Protected Campaigns
Medium 5.3
CWE-200Fixed in 2.4.3
- ID
- WPSEC-2026-1661
- Plugin
- Better Payment – Instant Payments, Donations, Fundraising with Subscriptions & More (better-payment)
- Affected
- from 2.2.0 before 2.4.3
- Remediation
- Update to 2.4.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-26
- Attack surface
- Better Payment on WPSec AttackSurface
- Fix released
- Published
Description
The Better Payment plugin for WordPress is vulnerable to Sensitive Information Exposure via password-protected campaigns in all versions up to, and including, 2.4.2, due to the single campaign template, the [bp_campaign] shortcode and the campaign block rendering a campaign without checking whether it is password protected. This makes it possible for unauthenticated attackers to view the full content, figures and Donate button of password-protected campaigns without knowing the password.
References
- https://wpsec.com/vuln/WPSEC-2026-1661/
- https://plugins.svn.wordpress.org/better-payment/tags/2.4.3/
- https://wordpress.org/plugins/better-payment/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS