Vulnerabilities / Zotpress / WPSEC-2026-1667

Zotpress <= 7.4.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via zotpressInText Shortcode

Medium 6.4 CWE-79Fixed in 7.4.5
ID
WPSEC-2026-1667
Plugin
Zotpress (zotpress)
Affected
all versions before 7.4.5
Remediation
Update to 7.4.5 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
Attack surface
Zotpress on WPSec AttackSurface
Fix released
Published

Description

The Zotpress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'item' and 'items' attributes of the zotpressInText shortcode in all versions up to, and including, 7.4.4. This is due to insufficient input sanitization and output escaping: the attribute values are passed through html_entity_decode(), which turns entity-encoded markup back into live HTML, and are then printed without escaping in the in-text citation markup and in the item list that the zotpressInTextBib shortcode outputs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0